1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You might experience slow forums at times. This is due to DDoS attacks on another IP on the server.
    If the problem continues throughout the day, we will move the forums to another server.
    The forums might also go down a few times today for server tweaking and similar.

cannot install driver for win 8 64bit

Discussion in 'NEO X7' started by kessiyean, Aug 14, 2013.

  1. kessiyean

    kessiyean New Member

    Hello,
    I wanted to install the new firmware on my minix neo x7. The current firmware always hangs up. But Windows 8 64 Bit dont find any driver.

    I give win 8 the path to extracted firmware where I found the driver file for win 8. But win 8 says it dont find anything. In the driver file c:/drivers win 8 found nothing too. I copy the driver file to c./drivers and give win 8 the path. But win 8 dont find them.
    Online search too. I also felt that that windows do not look right. It immediately jumps to -> no driver found.
    I deactivated the unsigned driver installation for win 8. But nothing helps.
    I have only USB 3.0 ports and I tested a mini USB-Hub too. But nothing.
    I changed in the config in RK Tool the one line to true but nothing helps. I do not get the win 8 driver installed.

    The only one where I come was the original recovery mode.

    Can I flash the firmware with any other methode? Or any other thing what I can do to install the win 8 driver?
  2. MINIX

    MINIX Administrator Staff Member

    Do you have another PC? The driver is tested and verified OK...
    It does not work with usb 3.0 port...
    Sent from my GT-I9500 (which I hate very much) using Tapatalk 2
  3. Hello Kessiyean, let me try to help U if I can, with the permission of Minix, of course :)

    First of all, try, if u didnt, to completly unistall the driver that windows installs by defect, in devices administrator > Right click > Uninstall... or something like that, excuse my bad english. (All with your Neo X7 unplugged, of course)

    Then, U have two options, both to be executed under Win 8 + unsigned drivers allowed:

    1) With your Minix powered off, connect it to power supply, and with usb oTg to your USB 3.0 (It works, I tested in mines). Then, while you hold the little button of recovery, press the power button for 3 seconds too, check the driver install prompt and redirect it to your drivers folder.

    2) If step 1 didn't solve your problems, uninstall all drivers, unplug everything, and download, install and run MOBOROBO (http://www.moborobo.com/). Under unsigned drivers allowed again, and with MOROBORO running, connect your minix again, power it and allow in settings>development the usb debuggin, and in settings>usb the USB connectivity. If all works, MOROBORO will detect your minix, download the drivers and execute an stand alone process to install the drivers, just follow the septs and simply click on "Install it anyway" when prompted.



    Hope this helps U m8, if you have any question, feel free to ask.



    *NOTE: In the rare case windows were detecting your MINIX as an MTP USB device, google it, u need to solve this first!
  4. kessiyean

    kessiyean New Member

    No, dont have another PC
  5. Kessiyean, try step 2 of my post, it worked here using USB 3.0. Have a nice day!
  6. kessiyean

    kessiyean New Member


    Win 8 install defeced devices? I will search.

    The first step I try yesterday. that dont work fore me.

    But step 2 is new :) will try.
    are you german? I am german :) My english is bad too.
  7. No, I'm from Spain. Win 8 install defect drivers, but using the program in step 2 it will install drivers for U if Windows didn't. Just remember to restart windows 8 in unsigned drivers allowed mode, if not u will get stuck while trying to install drivers. And also remember to enable usb debuggin and usb conectivity in your MINIX, and plug in it while u are running MOROBORO, it will do the work for you :)
  8. kessiyean

    kessiyean New Member

    OK, that worked. :) Know I have an USB ADB Device. But how to change MTP to right one?
  9. In some rare cases, Windows fails to install the driver and detects your device as an MTP USB device that cant be uninstalled. If you search in google, you will find some solutions to that problem, the two steps that helped me are:

    1) - with regedit search {EEC5AD98-8080-425F-922A-DABF3DE3F69A}” en HKEY_LOCAL_MACHINE /SYSTEM / CURRENT CONTROL SET/ CONTROL/ CLASS
    - Click on it and, at right side, select the item named "upper..." and delete it.
    - Restart.
    2) - Search the file wpdmtp.inf in C;\Windows\INF\ and delete it.

    * In some cases, problem is caused by the android device, then it might be solved by simply clearing the cache for an app called MTP extension service (this is an app that is not included in all Android devices). Also make sure USB Debugging Mode isn't enabled under Settings > Developer Options.

    All credits for those guys who posted their knowledge at so many forums :)

    Have a nice day!
  10. kessiyean

    kessiyean New Member

    Hmm when I plug in the minix with otg cable... minix off... push recovery and power button... win 8 search the driver and diddnt found it. Its se same like befor. Or I must install the firmware in normal power modus? Via setting menu - Firmware update?
  11. Do not use Firmware update, as Minix Team said that it may corrupt your system.

    When windows ask for drivers, click on select by yourself and redirect it to the folder where u have the downloaded drivers from Minix then (With unsigned compatibilty allowed, ofc)

    As I dont want to extend this thread for so long, feel free to add me in skype and whe talk directly if you need it, just PM me. :)
  12. hassie54

    hassie54 New Member


    I have install your driver but it is still the same. W8 don’t find the driver. I give the right path.
    I have allso try with the software moborobo. But the software find no drivers.

    So, you understand I need that driver installed. I must update the fw.

    HELP!!!!!!!!
    Last edited: Aug 14, 2013
  13. for those who have problems with the driver, add me in skype, PM, and lets see if I can help U, i had the same problem yersterday and solved it
  14. kessiyean

    kessiyean New Member

    Dont understand. Why should I dont use the firmware Update from minix?
    Windows didnt find the driver after all like the same I do not anything like moborobo an so on.
    Dont have skype. I only have msn messenger.
  15. hassie54 solved his problem and updated finally.
    I dont have more time today, maybe tomorrow i can help you too.
    Anyway im thinking about making a tutorial to do it under Windows 8.
  16. hassie54

    hassie54 New Member

  17. kessiyean

    kessiyean New Member


    That would be nice. I only have win 8 with usb 3.0 and I can flash my handys too. There are no problems and I dont understand while the minix make so much problems.
  18. You can flash under win 8 + usb 3.0. I did here. See the tutorial in the forum Kessiyean, take it easy. Good luck

Share This Page