1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. We are moving the forum:
    The new forum you can find here:

    www.minixforum.com

  3. We are moving the forum:
    The new forum you can find here:

    www.minixforum.com

  4. I have turned off the ability to post in this forum except for staff members. Please post at our new forum www.minixforum.com

How to install firmware updates

Discussion in 'General' started by Shane Webb, Jan 19, 2013.

  1. Shane Webb

    Shane Webb Member

    I am trying to follow Video tutorial to upgrade X5: http://www.youtube.com/watch?v=B0ivqTAx8hA&feature=youtu.be However, after cutting down my cable and ensuring that it fits snugly into port, I have tried to power on the device while holding in the recover pin with a tooth pick. The device powers on but I am not seeing any indication that Windows is picking anything up, I have tried this on 2 Windows 7 PCs, I do have the rockchip batch tool up and running.. am I missing something?
  2. Mark lim

    Mark lim Active Member

    I have the same issue too with my Neo G4. I discovered that it was due to me setting my settings as tick for USB debugging.

    After I untick it, after a few tries, windows was able to detect my device. Still its a hit and miss thing, but after less than 10 attempts, I manage to have one successful connection and I updated my Neo G4 to the latest firmware.

    The only 100% method that work is as per what a guy show in his video : 1)connect device via micro usb cable (one end to OTG port the other end to PC) and use it to power on the G4 or X5 2)Either U have a second monitor or u plug the cable from your pc to your device 3)Go to settings, - Unsder developer options, untick USB debugging then Under Storage>Set to Mass storage then under USB>Tick Set to connect to PC 4)Install the device driver 5)Open up flash tools and update the device.
  3. Shane Webb

    Shane Webb Member

    Hi Mark,

    Thank you for the advice, I have went to settings and found that I did not have connect to PC ticked, so with my new found excitement, I quickly checked the developer settings and ensured that USB debugging was also not set. However again the same issue.. I am opening the device manager and expecting to see something show up there in the other area, so I can install the drivers and get this working.. but it is just not happening
  4. ZMEU.NET

    ZMEU.NET Member

    I can offer XP support only lol
  5. Shane Webb

    Shane Webb Member

    I have now spent 5+ hours on something that should have taken only 5mins. If I can not get this to work by Tuesday, as Monday is a holiday, here I am going to have to send this back and find something else. It is a shame too because on the surface this seems to have everything we need, and we were going to recommend it to our customers for our Asian movie streaming website.
  6. geolemon

    geolemon New Member

    I was surprised to find exactly this symptom using the stock cable supplied WITH the X5.
    And I found that when I shaved the cable down as the video author shows, I was able to insert it further - at which point Windows did in fact recognize a device... and promptly fail to install the drivers, but this isn't totally unexpected, this isn't exactly a mainstream device.
    I'm guessing you still need to shave a little more off the cable. I probably cut back a full millimeter.

    Plug it in, push a paperclip or toothpick into the "Recover" hole until you feel it click, hold it there as you hold the power button for a few seconds, keep holding the "Recover" button until Windows at least says "unrecognized device" and tries to load drivers that it doesn't yet have. Your problem might also be that the toothpick is too wide for the hole, and accordingly you aren't really pressing the button in. You'll feel a distinct "click" I used a paperclip.

    Not shown explicitly in the video:
    Open Windows Device Manager. Right-click on the "unknown device" and "Update Driver Software". Microsoft will again try to automatically install drivers for the device. I forgot what I did specifically, but you have to navigate your way through the stupid Wizard until you get to an option where you can install the drivers from a location YOU specify. Browse to the appropriate folder under RockUSB Driver (whether 32 bit or 64 bit, then your specific OS).
    Once the driver is installed, it'll show up in the Device Manager just as the video author's does.

    Then - you can't miss the button to the right of "FW Path" - you need to pick the firmware to flash or nothing will happen. Watch very close, the author clicks on it quickly in the video and picks the firmware, which appears with Chinese on his screen.

    If you've taken care of those details, when you click on "Restore", it should load the firmware.
  7. Shane Webb

    Shane Webb Member

    Hello Geolemon,

    Thank you for the update.. I have already moved to a paper clip, and removed alot of the rubber, I am sure I am getting a tight connection, and have tried on Windows 7 PCs, and even tried it on my Linux Ubuntu PC that I mainly use, just to see if it detects something, however on all of them it is not detecting anything.. I have tested the cable it and works by charging my phone. I have even cut down my phone cable and tried that to no avail. I am starting to think maybe my OTG port on the device is faulty, but I am not sure how to test that
  8. Shane Webb

    Shane Webb Member

    From another post in here .. about installing the driver..
    My answer to this is NO.. I think this confirms that I have a bad OTG port, I have created an RMA to send this unit back to New Egg which unfortunately, I think I am going to have to do. I am going to get a replacement and try moving forward with a new X5 unit. After alot of research and comparison I have choose this product based on the support, ie new firmware releases, and this forum. Thank you to those that tried to help me along the way, I do hope that my next unit will not have this issue and we can recommended it to all of our users for our website.
  9. jackbenimble333

    jackbenimble333 New Member

    I had a similar problem with my Neo G4. My laptop would not recognize that my device was attached.

    My Dell Laptop has both USB 3.0 ports and USB 2.0 ports. I was connecting to a 3.0 port which should be backwards compatible with 2.0 but nothing was happening. After about an hour of messing around, I was just about to give up when I decided to give it one final try in a different USB port. Plugged into a USB 2.0 port and it took right off.

    Try a USB 2.0 port.
  10. Shane Webb

    Shane Webb Member

    Hi Jack,

    Thank you for the advice.. I had tried every usb port on several computers, and even an older one, however, none of them would recognize it. I have sent the device back last night. I hope to have my new one by the end of the week.
  11. jako

    jako New Member

    This whole update thing is kind of ridiculous. Minix, it's nice that you have some sort of presence on the internets, but at the end of the day it's about quality of information and product.
  12. Shane Webb

    Shane Webb Member

    Actually, this forum and Minix's firmware updates is what made me ultimately decide to choose Minix over of a few devices I was considering. I took much time trying to decide, because I wanted a solution, that I could trust, and recommend to members of a website. Now I have to admit it seems that I have gotten a faulty device on the first delivery, but I have had faulty devices from some better known names as well. I believe it is an inherited risk with electronics now days as they are very complicated. It appears many other users are getting good results, and I am willing to give another unit a try. The only draw back I can see with the update is you have to do a restore instead of upgrade, however seeing that this is only the second update released, I hope that they get that down and allow an update without a full restore, in the future. Still if you compare to most other companies Minix has put 2 updates in 30 days, where others will release only 1 update in the lifecycle if you get that even.
    Brian Dorset likes this.
  13. jako

    jako New Member

    Sorry, but your lengthy account sounds much like a post- hoc rationalization of a purchase. I think it has little bearing on my point - quality of information and product is more important than the occasional forum contribution. One could mount several arguments against your account, the most obvious being 'why should one even need an update a mere 30 days after release?'. Even if one allows this, the lack of guidelines and ease of the update are quite telling.
  14. Shane Webb

    Shane Webb Member

    I am not going to argue with you, if you do not like the product please by all means go somewhere else. It is a fact however, that new updates are released fairly often in android community, this devices is built on open source and not a proprietary version of android. If you prefer something more along those lines then maybe this is not the product for you.

    Case in point last Summer I purchased a Samsung Galaxy note 10.1 tablet with Samsung's version of ICS on it, when it was first released. Shortly after I purchased it (less than a month) JellyBean was released. Samsung stated that they would be releasing a new update to run JellyBean, which I am still waiting on. Now your faulting a very small company, for giving you an open source version JB that will work with their device, that provides enhancements, instead of pushing you to purchase the next version. This is the reason I choose this product over several others. Ask owners of other competitor products, I am sure they wish they could update their product without rooting it and voiding their warranty.
    Brian Dorset likes this.
  15. jako

    jako New Member

    Well if you're not going to argue, maybe you should have stopped after saying that.
  16. Ishi Carter

    Ishi Carter Member

    It's funny...when you buy a similar Western Digital product or some other big name product like this there are also plenty of updates...maybe even right after you buy it. Minix is working to fix everyone's issues as fast as they can. I, for one, appreciate it. So far I'm having a blast playing with emulators, watching Hulu, and watching all the other content my server running Playon provides me...even if XBMC isn't 100% *yet*. The Neo X5 is a great product loaded with very good hardware for the class of machine. It's at the top of it's class as one of these Android add-on boxes (because of the company's support and updates...no in spite of it) and as soon as XBMC is tweaked it'll be a much more useful device than my Asus O!Play ever was for the same $$$ I spent on the Asus device.

    Jako...I feel your expectations of these types of Android boxes are somewhat out of whack. Which one do you own and which ones on the market right now do you think are better? I'm only just starting to see similar products, and there's no telling what they're support is going to be like (other manufacturers have even been poaching Minix's work because they're having trouble supporting their own hardware).
    Brian Dorset likes this.
  17. jako

    jako New Member

    I agree the G4 and G5 are the best of the lot and we should all thank Google, and of course Linux/FOSS, for giving the OS away so that small companies like Minix can buy cheap hardware, enrich it and sell it. But, the G4 costs, here in Scandinavia, the same as Apple TV. Could you imagine Apple, Western Digital, D-Link, etc. asking people to watch a quite incomprehensible video, take a knife to their USB cable, install dodgy Windows drivers, etc. etc. just to update? Now to be fair, I'm not holding Minix to an Apple standard, just using it as a metric. While I applaud that Minix is occasionally responsive in various fora, I maintain that the way this update has to be done, and most importantly, the lack of documentation, detracts from a reasonably OK product. Minix is one of the best in its league, but, let's face, it is a league with pretty low standards. Maybe they'll advance to a better league, maybe they won't. The current update situation is not a good sign.
  18. Ishi Carter

    Ishi Carter Member

    Hrm...I didn't have problems with the drivers once I figured out how to reliably enter recovery mode. Yes, they "failed" to automatically install, but this is not uncommon in Windows for new devices as Windows can't always know every new piece of hardware on the market.

    The OTG cable thing was unfortunate...I'm sure hardware rev 2 will have this corrected, but even big companies have multiple revisions of hardware. There were at least 15 hardware revisions of the Playstation 2 that I can remember. Overall, the Neo X5 hardware has been extremely solid for me.

    I honestly have no desire to own an Apple TV regardless of the cost...I can do so much more with the Minix hardware. After it's served it's life as my multimedia box, it can easily be converted to many other duties (NAS server, VPN endpoint, Wireless AP, FTP server, web server, mini PC, wireless printer sharing device, etc). The Apple TV will be in the garbage once it's days as a media center are over. Can't even play MKV files on it until you jailbreak it (don't think a jailbreak is available for current gen Apple TV) last I read...and I'm willing to bet there's a lot more you can't do with it unless you jailbreak it. I can do a ton with the Minix box without having to root it...or I can root it and have a really nice Android dev box (if I want to do that). The Apple TV is somewhere between a Roku streamer and the Minix box IMO.
    MoeDee, onelovekir and Brian Dorset like this.
  19. jako

    jako New Member

    1) The description of your own problems with Windows drivers illustrates nicely my point. Let me also add that it doesn't exactly instill confidence that the only way to upgrade a system which is basically Linux plus Java is through Windows, not known to be the os of choice for the technically inclined.
    2) Oh, so Minix will be sending out free upgraded devices because of the engineering/manufacturing/QC error in my HW version?
    3) My claim has nothing to do with the qualities and capabilities of the Minix, or any other device. It's about the update procedure. How you want your prn packaged and delivered is really up to you, but sooner or later you will want to update the device and it should be a lot easier than it currently is for the Minix devices.
  20. Ishi Carter

    Ishi Carter Member

    #1) This is a limitation of Windows. The only thing Minix can do to mitigate the situation is make an installer for the drivers that will make it easier to pick up the driver automatically. It doesn't mean there's anything wrong with the driver itself (which is the gist of what I get reading your complaint). The driver, so far, has worked perfectly the one time I needed to use it.

    #2) I highly doubt it...just like Apple never sent out replacement iPhones when it was proved beyond a doubt that there was a flaw in the antenna. At least Minix figured out the problem and owned up to it...unlike Apple which basically said that people were talking on their iPhone wrong.

    #3) I'm not sure I understand your point about updating the firmware being a hassle. I haven't had a chance to test it out, but didn't they enable OTA upgrades that circumvents the need for messing with Windows drivers, cables, or recovery mode (also invalidating issue #1)? The only other improvement to the update process is an official inclusion of something like CWM where I can also flash it from SDCard/USB (but that's really just gravy).

    ...and just FYI, while I don't really care if other people watch porn (not my business), I avoid keeping anything pornographic in my house including vids. I have kids that I don't particularly want stumbling onto it and believe that the frequency a lot of people watch it is damaging in very subtle ways. I *AM* however, sick of people "borrowing" my DVDs, the occasional outright thief that feels it's ok to just walk off with your movies (like the guy who broke in a few years ago and took my binder full of DVDs), and my kids who...no matter how much I explain to them how to take care of DVDs still manage to scratch the $#(@ out of them. I now rip my DVD's and store the files...then store the movies away from where people will casually have access to them. Storing DVD isos take up too much space. MKV seemed as good a container as any and has been supported fine by my previous media players...re-encoding DVDs takes a long time and I don't really feel like re-encoding my collection just so I can purchase an Apple product. I'm honestly surprised the Apple TV supports as many formats as it does, but I don't feel comfortable routing everything I use through iTunes just to use the Apple TV.
  21. jako

    jako New Member

    It's my understanding that we have to do this fudge of an update first before we get the OTA. I'd love to be wrong. Your insights on Apple's products may be valid, but they say nothing against my claim. Even if they were valid, how does it counter my argument if other products might be just as bad? Are we racing to the bottom? As for your rant on porn and your DVD's, well ....
  22. Ishi Carter

    Ishi Carter Member

    Mostly I thought your generalization that I only wanted MKV files so I could view porn was unnecessarily personal and insulting.

    ...but whatever...done...carry on hating.
  23. MoeDee

    MoeDee Member

    Enough said.

    Please close thread.
    By now there should be enough info on how-to update.
    ..the first 10 posts probably.

    Sent from my ADR6350 using Tapatalk 2
  24. Just got my Minix Neo X5 today. Super stoked! While tinkering with it I seen my kernel was built on 1-17-2013 but my build number is from January 2012. So does that mean I'm on the newest firmware? I think so but I'm not for sure.

    Sent from my HTC VLE_U using Tapatalk 2
  25. Shane Webb

    Shane Webb Member

    Hi Matt, check the version of Android mine came with 4.04

Share This Page