1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You might experience slow forums at times. This is due to DDoS attacks on another IP on the server.
    If the problem continues throughout the day, we will move the forums to another server.
    The forums might also go down a few times today for server tweaking and similar.

Guide Rooting your x5

Discussion in 'MINIX NEO X5 Guides & FAQs' started by KeepInItDroid, Jan 10, 2013.

  1. Crusty

    Crusty Member

    Ok
    I found instructions for flashing CWM by putting the update on a sd card and accepting to install but after rebooting it has not installed and then asks to delete the file.
    I tried several times and also by reinstalling the latest minix firmware but still CWM won't install.
  2. ebianchi

    ebianchi New Member

    neog4 so i have to rename it as update.zip and put it on the sdcard or i haveto reboot it in recovery mode and what then ?
  3. Crusty

    Crusty Member

    I copied the file to the sd card and renamed it update.zip. It then prompted me to install the update, at that point it rebooted and an android logo appeared with a red exclamation mark. After a couple of minutes the X5 rebooted into the original screen and told me the update had failed.
  4. ebianchi

    ebianchi New Member

    Crusty you are talking about the cwm, aren't you? try again my installation went smooth I put the update file in the sdcard, I rebooted and then an alert poped out saying do you want to install cwm and i said yes...
  5. Free Radical

    Free Radical Active Member

    Crusty: This method involves installing cwm recovery. You need to install it using the update.zip method. If that doesn't work (as in ICS 4.0.4), there is a more arcane method of installing it over adb (needs roots so purpose of this thread is defeated) or flashing it through Finless' rockchip tool which is I won't suggest to new users as it can brick your device. Just read up on how to install cwm recovery properly first before you proceed to do anything complex. Having a working cwm recovery would help you make and restore from total system "nandroid" backups which can help you in difficult situations.

    ebianchi. You needn't rename the superuser package. Put it in /sdcard or /external_sd and in clockworkmod recovery, select the option "install zip from sdcard" or "install zip from external sdcard" respectively
    ebianchi likes this.
  6. Crusty

    Crusty Member

    Got there in the end
    I was trying to install cwm from external sd card
    Thanks for your help
  7. Konstigt

    Konstigt Member

    When I select Developer Options in Settings, Settings closes! Anyone seen this? Why? Tried it 10 times, always closes when I select it. Accessability & About works (above and below dev. options).

    Firmware 20130326, version 010

    Edit: Problem went away after reboot.
    Last edited: Apr 23, 2013
  8. Konstigt

    Konstigt Member

    I just rooted my X5 but not with this guide. Instead, just copied CWM (from http://minixforums.com/threads/recovery-cwm-6-0-2-8-for-neo-x5-g4.181/) to update.zip in the root of the virtual sdcard (/sdcard/update.zip). Also copied SuperSU-zip there. Got a popup asking if I wanted to install update.zip, accepted. Then from CWM after install, also flashed SuperSU.

    Done!
    hstegeman likes this.
  9. Robert M

    Robert M New Member

    Ok the Tsparky adb pack is reporting "out of date" and aborts. its possible there is a slash command that ignores it, but what i did was get updated files instead.
    i replaced adb.exe + adbwinapi.dll + adbwinusbapi.dll with up to date ones from the android SDK. @ http://developer.android.com/sdk/index.html

    otherwise it worked like a charm.

    Some people report issues with using the update.zip way so this is one way to go about it.
  10. parkpop

    parkpop New Member

    How can I root my X5 mini, it's not the same as X5?
  11. ski522

    ski522 Active Member

  12. Kenan Elmas

    Kenan Elmas New Member


    Is that package works for X5 Mini 4.2.2?

    Thanks.
    felix likes this.
  13. felix

    felix New Member

    I would like to know it too. Thanks
  14. jornhd

    jornhd New Member


    Thanks! That worked very well! Very nice to be able to do the whole process on the device itself without any pc. :)
  15. felix

    felix New Member

    HI, are you on 4.2.2? Thanks

    Enviado desde mi Nexus 7 mediante Tapatalk
  16. jornhd

    jornhd New Member

    Yes.
    felix likes this.
  17. felix

    felix New Member

  18. jornhd

    jornhd New Member

    felix likes this.
  19. felix

    felix New Member

  20. jornhd

    jornhd New Member

    But how can I unroot after using this method?
  21. ski522

    ski522 Active Member

    Restore the firmware using RockchipBatchTool, it's sets everything back to stock.
  22. jornhd

    jornhd New Member

    I rooted just to fix the remote media keys, but if I restore I loose this change. Isn't there anyway to unroot without restoring the firmware? The reason I want to unroot is that I want to use a TV app that won't run on rooted devices.

Share This Page