1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB driver problem...

Discussion in 'NEO X5' started by bard, Apr 17, 2013.

  1. bard New Member

    Hi,

    I just got X5 and have problems updating the FW.
    I am currently using win7 64bit and have also tried a 32 bit laptop with win7. I am using usb 2.0 ports(black color). The firmware I am using is the latest on this site (NEO_X5_4.1.1_20130326.rar).
    My problem is the installation of the usb driver.
    This is that I do:

    1. Downloaded the firmware from http://minix.com.hk/firmware/NEO_X5_4.1.1_20130326.rar, I managed to do that :)
    2. Plugged the X5 to power and started it with a paper clip and holding power button for a while(I get the android maintenance screen)
    3. Connect usb cable to X5 and usb 2.0 port on my pc
    4. Windows fail to install driver
    5. I go to Device Manager and find the X5 listed under "Other devices" as "NEO-X5+"
    6. Right click "NEO-X5+" and choose Update Driver Software. Pick win7 64bit driver folder(...NEO_USBdriverV3.5\Win64bit\win7), but i get this error.

    "Windows could not find driver software for you device"

    I have read this thread as it looks a lot like my problem => http://minixforums.com/threads/usb-driver-trouble.1328/#post-7599
    But the thread has no answers.

    So I need some help... :)

    ~b
  2. bard New Member

    No help, MINIX admin?
  3. Ed1 New Member

    knock, knock...
    How about answering... i have the same problem and i've been waiting for the answer too!!!
  4. AndreaSpooky New Member

    same problem here
  5. bard New Member

    MINIX admin ???
  6. scooter2011 Well-Known Member

    Hi All
    when you download firmware usb drivers located in that file. Simply unplug neo5 replug in and when windows requests the drive select install from file go to where you unzipped tbe update ,select usb folder reboot windows once installed and you should be good to go. This is on tbe site and you should look for it before posting that minix has time to fix real issues.

    Read read read. Then read some more it actually doez work;)
  7. bard New Member

    Of curse I have read on this forum. I have even seen a video, but no help...
    http://minixforums.com/threads/trouble-to-install-rockusb-driver.106/
    http://stuff24.de/blog/minix-neo-x5-android-rom-jelly-bean-firmware-upgrade/

    If I follow your instruction without using a paper clip I just get to browse the content of the X5. I think that is normal behavior.
  8. Woolywonder New Member

    I've had this problem as well, I've tried everything!! I've read read read then read some more, I've watched video tutorials for a week now....no luck. To me (a non-geek) this is a real issue. Minix has a duty to help ALL customers get the best from their X5s, not just the geeks. I'm really suprised Minix released the X5 with so many issues to iron out. It's a bloody nightmare:mad:
  9. scooter2011 Well-Known Member

    Anwser to bard.

    You missed installing drivers from the file you downloaded usb drivers are in that zip. When windows asks to install drivers select that usb file to install drivers from and then attach usb for neo5 run batch program then start neo5 with paper clip depresses before hitting power soon as blue light comes on release now batch file should turn green .
  10. scooter2011 Well-Known Member

    Your not trying to see files all your trying to do is get the batch file program (that is in same file as usb drivers) to see the neo 5 once that program sees the neo it will will turn green in the batch program.
    Then your able to update neo5, and yes you have to start neo5 with the pin depressed to get batchile program to see it.
  11. ALWAYZBLESS Member

    I remember when I first tried to install the drivers I had this problem as well, I actually was able to resolve it by selection the folder for the 32bit drivers instead of using the one for the 64 bit drivers.
  12. bard New Member

    I don't understand you.... or maybe I do. You are saying that I don't pick the driver from the rar file....?
    As I said in my first post where I describe all the steps I do...

    >6. Right click "NEO-X5+" and choose Update Driver Software. Pick win7 64bit driver
    >folder(...NEO_USBdriverV3.5\Win64bit\win7), but i get this error.
    >
    >"Windows could not find driver software for you device"
    >

    ...I pick the driver from the rar file I have downloaded, but that part is not working!

    Btw this is not the first time I have installed USB drivers for various devices. I guess I installed my first usb driver back in 1995 or maybe earlier.
  13. bard New Member

    Tnx :) I will try that when I get home...
  14. scooter2011 Well-Known Member

    Then your down load must bad as usb drivers included in all updates are good are you installing tje update from minix site? Or is this a custom rom your trying to install.when you plug neo5 and start it up it will request the driver. Thats when youpick theusb drivers in zip file with the update there is intel and amd files so match your processer.
  15. Jan Bos New Member

    I have the same problem, my Neo X5 always shows up as Neo X5+ in my device manager. I removed the device, tried again and again. I have the latest firmware with the USB 3.5 drivers but Windows 7 simply refuses to install the drivers when I point windows to the correct folder. Simply keeps telling me no divers found. I tried the Win32 and the win64 drivers. I also tried downloading the 3.5 USB drivers as a seperate package from the Minix website, same results because the files are the same.
    I tried the paperclip in the back holding the mini switch, then powering up and it does not matter which way I try, it always shows up in the device manager as Neo 5+. The firmware flash tool never turns green because the drivers are not installed.
    Windows does find it, I can also see the flash-drives in explorer but I simply can't get the dsrivers to install.
    Running W7 64bit in case this matters. I tried 2 different computers and the same results, impossible to install te drivers.

    Any help would be greatly appreciated.
  16. Jan Bos New Member

    Update: I got it to work! Here is what happened to me and how to avoid the same problem as I had. I had Windows set to automatically instal the drivers and this causes Windows to immediately go out and search for the correct drivers. It will install the MiniX as Neo 5+ device but without drivers. It does recognise the MiniX but has no drivers for it.

    I uninstalled the Neo 5+ from the device manager list, disabled automatic driver installation in Windows and when I plugged the MiniX back in after powering it up with the paperclip holding the recovery button, Windows found something and asked me what to for driver installation. I chose to manually select the driver and pointed Windows to the downloaded files which includes the new USB 3.5 drivers. I selected W7 64b drivers and Windows installed the drivers correctly. I then started the Flashtool without disconnecting the MiniX and the light went green. Installed the new software and waited till the reboot was completed. Exited the flashtool and powered the MiniX down and connected it to the TV and voila, all is well and I am up and running with the new firmware.

    New firmware is awesome and I am enjoying my new MiniX!

    Hope this helps others with the same problem, good luck!
    jacuzzi likes this.
  17. Irv47 New Member

    Very helpful instructions. Besides the Neo+5 I ran into 2 entries above that that referenced a base station. I removed them along with the Neo +5 entry, unplugged and replugged the x5 power, pressed recovery pin and power and the got an "unknown device" entry which I right clicked on and installed driver from 3.5 usbdriver folder from Minix download. The device manager showed an entry fro rockusb device under computer. Ran the flash tool and it turned green. Flash went through with no problem.

    For some of the new people here please explain disabling automatic driver installation. Thanks
  18. scooter2011 Well-Known Member

  19. Woolywonder New Member

    Cheers Jan, thank's to you, new firmware up and running:) only problem is, I can't seem to put the m5 to sleep. It shuts down for a few seconds then wakes up again:confused:
  20. Jan Bos New Member

    Woolywonder,

    I had the same problem, I am using a wireless mouse and when I put it to sleep it almost immediately wakes up again. Here is what I found out: if you put it to sleep it will go to sleep but it wakes up almost immediately when you move the mouse. So if you want to put it to sleep you can but don't move the mouse! When you do, it wakes up again, even a little tiny movement of the mouse wakes it up. I now first click on the power icon with my mouse and wait til the 'sleep, off and reboot ' dialog pops up. I then switch off my mouse (I got one of those el cheapo chinese with a power switch on the bottom, made by Rapoo) and use the remote control to click on the sleep button. I don't have an air-remote, just the basic remote that came with it. If I want to wake it up again, I just have to switch on my mouse and tadaaaaa it is back.

    Hope this helps, let me know and good luck. :)
  21. Woolywonder New Member

    Thank's again Jan. I followed your instructions and it was indeed mouse movement. All sorted now:)
  22. bluenose63 New Member

    Ok my problem is minix x5 shows up as unrecognised device in device manager fine when I connect it to laptop, but when I try to install drivers it says windows was unable to install to your unknown device? when i look in properties I get this message Windows has stopped this device because it has reported problems. (Code 43)

    I have tried to install drivers for USb from from Minix Official Firmware, Finless Custom Rom 1.2b, and neither of them will work.

    I have stopped Windows doing the automatic driver updates and still no joy.

    This is very frustrating I am using Windows 8 x64 and it just won't install the drivers, is there a way round this?
  23. bluenose63 New Member

    Still hoping for an answer, still can't install the usb drivers for the minix through my windows 8 laptop.

    Just tried taking the power cable and taking out battery on laptop in case it was a problem with the laptop, no joy, so back to the minix box, it shows up as unknown device fine in device manager, it simply won't install the drivers.

    Any other workarounds please from the ones I have listed in my previous post
  24. Raph4 Member

    for Win 8: Disable Driver Signature Enforcement in Windows 8

  25. bluenose63 New Member

    Thanks for video, followed instructions tried it and it still doesn't work........

    This means nothing to me but may do to someone, who can help me with my problem?

    Clicked on Driver Properties/events of unknown device and info states

    15/05/2013 12:40:15 Device Configured (null)
    15/05/2013 12:40:15 Device Not Started
    Device USB\VID_0000&PID_0000\5&514b289&0&3 was configured.

    Driver Name: null
    Class GUID: {00000000-0000-0000-0000-000000000000}
    Driver Date:
    Driver Version:
    Driver Provider:
    Driver Section:
    Driver Rank: 0x0
    Matching Device ID:
    Outranked Drivers:
    Device Updated: false

    + System

    - EventData
    DeviceInstanceID USB\VID_0000&PID_0000\5&514b289&0&3
    DriverName null
    ClassGUID {00000000-0000-0000-0000-000000000000}
    ServiceName
    LowerFilters
    UpperFilters
    Problem 0x2b
    Status 0x0

Share This Page